In my earlier posts I explained how to configure Vyatta as a router in VMware Workstation. Unfortunately Vyatta Community Edition is no longer available since Winter 2013. Luckily for us community fork **VyOS **started being developed so great router software still can be used for free.
VyOS
VyOS is a community fork of Vyatta , a Linux-based network operating system that provides software-based network routing, firewall, and VPN functionality.
Runs on both physical and virtual platforms.
Supports paravirtual drivers and integration packages for virtual platforms.
Completely free and open source.
You can download it for free using this link http://vyos.net/wiki/Main_Page .
How to migrate from Vyatta to VyOS?
Installaton of VyOS is as simple as Vyatta and there shouldn’t be any problem if you follow my earlier guides.
https://www.wojcieh.net/vyatta-router-running-on-vmware-workstation-part-1/
https://www.wojcieh.net/vyatta-router-running-on-vmware-workstation-part-2-dns-firewall-and-nat/
https://www.wojcieh.net/vyatta-router-running-on-vmware-workstation-part-3-firewall-hardening/
In order to migrate from Vyatta to VyOS we need to save current config from Vyatta and import it into VyOS. Please execute following command: show configuration commands and after that you will get nice and easy to implement commands in VyOS.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
set firewall all-ping 'enable'
set firewall broadcast-ping 'disable'
set firewall ipv6-receive-redirects 'disable'
set firewall ipv6-src-route 'disable'
set firewall ip-src-route 'disable'
set firewall log-martians 'enable'
set firewall receive-redirects 'disable'
set firewall send-redirects 'enable'
set firewall source-validation 'disable'
set firewall syn-cookies 'enable'
set interfaces ethernet eth0 address '192.168.255.250/24'
set interfaces ethernet eth0 description 'WAN'
set interfaces ethernet eth0 duplex 'auto'
set interfaces ethernet eth0 smp_affinity 'auto'
set interfaces ethernet eth0 speed 'auto'
set interfaces ethernet eth1 address '10.0.0.1/24'
set interfaces ethernet eth1 description 'LAN'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 smp_affinity 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces loopback 'lo'
set nat source rule 10 description 'LAN to WAN'
set nat source rule 10 outbound-interface 'eth0'
set nat source rule 10 source address '10.0.0.0/24'
set nat source rule 10 translation address 'masquerade'
set service dns forwarding cache-size '150'
set service dns forwarding listen-on 'eth1'
set service dns forwarding name-server '192.168.255.254'
set service ssh port '22'
set system config-management commit-revisions '20'
set system console device ttyS0 speed '9600'
set system gateway-address '192.168.255.254'
set system host-name 'router'
set system login user vyatta authentication encrypted-password 'PASSWORD'
set system login user vyatta level 'admin'
set system name-server '192.168.255.254'
set system ntp server '0.vyatta.pool.ntp.org'
set system ntp server '1.vyatta.pool.ntp.org'
set system ntp server '2.vyatta.pool.ntp.org'
set system package auto-sync '1'
set system package repository community components 'main'
set system package repository community distribution 'stable'
set system package repository community password ''
set system package repository community url 'http://packages.vyatta.com/vyatta'
set system package repository community username ''
set system syslog global facility all level 'notice'
set system syslog global facility protocols level 'debug'
set system time-zone 'GMT'
Copy In my case installation and migration took somewhere about 5 minutes.